fbpx
  • slide 1C cloud 3
  • slide microsft
  • slide aida64
  • Тест производительности сервера DELL PowerEdge R210 II
  • Дергается курсор мышки в Windows 7. Решение
  • Установка драйвера ATI Radeon 9000 на Windows 7
  • Новый Adobe Photoshop CC взломан через день после релиза
  • Бесплатное безграничное облачное хранилище Hive
  • Уникальный игровой сервис OnLive
  • Иван Царевич,DjTro - Сталь манит кровь
  • Dj Tro - For my sole love [2002]
  • С Днем Программиста 2017
  • Печать табличного документа через общую форму печати в УНФ
  • Поднимаем FPS в играх в Windows 10
  • Как сделать перчатки сенсорными
  • Китайцы назвали WINDOWS 8 угрозой для страны
  • Знакомство с Windows 8. Взгляд с близка.
  • Ролик про Крым
  • PDFZilla. Конвертор из PDF в Word.
  • Mortal Kombat Komplete Edition официально анонсирован для PC
  • SDI - все драйвера в одном пакете
  • Assassin's Creed 4: Black Flag. Преимущества игр нового поколения.
  • Огромное облачное хранилище Yunpan 360 на 36Тб
  • Секретарша и лист
  • Сброс пароля пользователя на MacOS
  • Прошивка MAC-адресса в интегрированной сетевой карте
  • Полноценная ОС для слабых машин
  • Решение ATI Radeon HD3000/4000 Overscan/Underscan
  • Windows Server 2016 доступна
  • С Днем Программиста 2012
июнь27

Создание внешней печатной формы по стандарту БСП (тонкий клиент)

Троцкий Юрий

Создание внешней печатной формы по стандарту БСП (тонкий клиент)

Создание внешней печатной формы для тонкого клиента

тонкий клиент

 

По сравнению с созданием внешней печатной формы для толстого клиента - работа с тонким клентом получила плюсы в возможностях и минусы в разработке. На толстом клиенте было достаточно создать внешнюю печатную форму и далее в режиме предприятия указать, к какому объекту (справочнику или документу) она будет применена.

Если вы хотите создать внешнюю печатную форму для тонкого клиента, подключить его родными средствами конфигурации и при этом не городить самому дополнительный код для ее вывода, для конфигураций, построенных на Библиотеке Стандартных Подсистем (БСП), например таких как УПП 2.0, БП 3.0, УТ 11, УНФ - ниже приведен пример.

  1. Создаем внешнюю обработку
  2. В Макетах создаем "НашМакет" 
  3. Дальше тот самый особенный момент - в модуле объекта создаем следующие процедуры и функции:
Функция СведенияОВнешнейОбработке() Экспорт

ПараметрыРегистрации = Новый Структура;
МассивНазначений = Новый Массив;
МассивНазначений.Добавить("Документ.ЗаказПокупателя"); //Указываем объект куда будет подключена внешняя печатная форма

ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма");
ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
ПараметрыРегистрации.Вставить("Наименование", "Спецификация");
ПараметрыРегистрации.Вставить("БезопасныйРежим", ЛОЖЬ);
ПараметрыРегистрации.Вставить("Версия", "1.0");
ПараметрыРегистрации.Вставить("Информация", "Спецификация");
ТаблицаКоманд = ПолучитьТаблицуКоманд();
ДобавитьКоманду(ТаблицаКоманд, "НазваниеНашейПечатнойФормы", "НазваниеНашейПечатнойФормы", "ВызовСерверногоМетода", Истина, "ПечатьMXL"); //Пишем как будет отображаться название нашей печатной формы в предприятии
ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
Возврат ПараметрыРегистрации;
КонецФункции

 

Функция ПолучитьТаблицуКоманд()
Команды = Новый ТаблицаЗначений;
Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
Возврат Команды;
КонецФункции

 

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
НоваяКоманда = ТаблицаКоманд.Добавить();
НоваяКоманда.Представление = Представление;
НоваяКоманда.Идентификатор = Идентификатор;
НоваяКоманда.Использование = Использование;
НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
НоваяКоманда.Модификатор = Модификатор;
КонецПроцедуры

 

Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "НашМакет", "НашМакет", СформироватьПечатнуюФорму(МассивОбъектов[0], ОбъектыПечати)); //Смотрим внимательно на НашМакет
КонецПроцедуры 

 

Функция СформироватьПечатнуюФорму(СсылкаНаДокумент, ОбъектыПечати)
ТабличныйДокумент = Новый ТабличныйДокумент;
ТабличныйДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_НашМакет"; //Смотрим внимательно на название НашМакет
МакетОбработки = ПолучитьМакет("НашМакет");  //Тут пишем имя своего макета
//шапка как пример
ОбластьШапка = МакетОбработки.ПолучитьОбласть("Шапка");
ОбластьШапка.Параметры.НомерДокумента = СсылкаНаДокумент.Номер;
ОбластьШапка.Параметры.ДатаДокумента = Формат(СсылкаНаДокумент.Дата,"ДФ=dd.MM.yyyy");
ОбластьШапка.Параметры.получатель = СсылкаНаДокумент.Контрагент;
ОбластьШапка.Параметры.телефон = ПолучитьКОнтактнуюинформацию(СсылкаНаДокумент.Контрагент,"Телефон");
ОбластьШапка.Параметры.адрес = ?(ЗначениеЗаполнено(ПолучитьКОнтактнуюинформацию(СсылкаНаДокумент.Контрагент,"Факт. адрес")),ПолучитьКОнтактнуюинформацию(СсылкаНаДокумент.Контрагент,"Факт. адрес"),ПолучитьКОнтактнуюинформацию(СсылкаНаДокумент.Контрагент,"Юр. адрес"));;
ОбластьШапка.Параметры.ВалютаДокумента = СсылкаНаДокумент.ВалютаДокумента;
ТабличныйДокумент.Вывести(ОбластьШапка);
//И далее заполняем свой макет
Возврат ТабличныйДокумент; 
КонецФункции

4. После описания заполнения макета сохраняем его и в самой конфгурации добавляем как "внешнюю печатную форму или обработку". В зависимости от конфигурации этот пункт будет в разных местах - ищем. После добавления ваша печатная форма вольется в конфигурацию как родная и будет корректно отображаться в командах печати и самого объекта и на форме списка. Кстати, эти настройки тоже производятся уже в самом режиме предприятия при добавлении формы.

 

На этом все.

P.S. Так-же мы предоставлям надежное обланое хранилище для ваших баз 1С. Подробнее...

Комментарии (2)

  • rufreechats

    rufreechats

    14 июля 2020 at 05:43 |


    RuFreeChats.com — эротический вебчат нового поколения развратных и уверенных в себе молодых парней и сексапильных девушек. Тут самые топовые веб-кам модели ведут круглосуточные завораживающие эротические трансляции по вебкамерам. Никаких записей, все происходит в прямом эфире - тут и сейчас!

    Благодаря скорому развитию современных технологий, русские видеочаты для взрослого населения также активно развиваются в сети. Потому их стало такое множество, что сложно выбрать среди них наиболее привлекательный для себя, лучший русский секс видеочат. В чем заключаются различия между различного рода эро видеочатами?

    Если вас интересует вопрос что особенного в нашем эротическом видеочате 18+, тогда данная статья именно то, что вам нужно. Только тут вас ждут самые красивые и раскрепощенные девочки онлайн, которые умеют развлекать виртуальных зрителей. Ради токенов барышни готовы выполнить различные непристойные просьбы в прямом эфире. В данном эро чате вы также сможете увидеть, как развлекаются пары, мужчины, а также и трансы. Для любителей блондинок, брюнеток и рыжих также есть отдельные категории, а еще вас ждет очень интересный раздел новые модели. Начинающие веб актрисы классно отрываются перед объективами и делают практически все чтобы понравится публике. Благодаря удобной навигации вы сможете очень быстро и без особого труда выбрать онлайн веб девочку по душе.

    Получив от зрителей секс чата щедрые чаевые, шалунишки обнажаются в прямом эфире и приступают ласкать прелести в режиме реального времени. Находясь в порно чате, проказницы не только активно шалят, но и задорно общаются с парнями и женщинами.

    войти в чат к SashaAlice

    ответ

  • rufreechats

    rufreechats

    14 июля 2020 at 08:17 |


    RuFreeChats.com — эротический вебчат нового поколения развратных и уверенных в себе молодых парней и сексапильных девушек. Тут самые топовые веб-кам модели ведут круглосуточные завораживающие эротические трансляции по вебкамерам. Никаких записей, все происходит в прямом эфире - тут и сейчас!

    Благодаря скорому развитию современных технологий, русские видеочаты для взрослого населения также активно развиваются в сети. Потому их стало такое множество, что сложно выбрать среди них наиболее привлекательный для себя, лучший русский секс видеочат. В чем заключаются различия между различного рода эро видеочатами?

    Если вас интересует вопрос что особенного в нашем эротическом видеочате 18+, тогда данная статья именно то, что вам нужно. Только тут вас ждут самые красивые и раскрепощенные девочки онлайн, которые умеют развлекать виртуальных зрителей. Ради токенов барышни готовы выполнить различные непристойные просьбы в прямом эфире. В данном эро чате вы также сможете увидеть, как развлекаются пары, мужчины, а также и трансы. Для любителей блондинок, брюнеток и рыжих также есть отдельные категории, а еще вас ждет очень интересный раздел новые модели. Начинающие веб актрисы классно отрываются перед объективами и делают практически все чтобы понравится публике. Благодаря удобной навигации вы сможете очень быстро и без особого труда выбрать онлайн веб девочку по душе.

    Получив от зрителей секс чата щедрые чаевые, шалунишки обнажаются в прямом эфире и приступают ласкать прелести в режиме реального времени. Находясь в порно чате, проказницы не только активно шалят, но и задорно общаются с парнями и женщинами.

    секс чат с Elen498 вход

    ответ

Оставить комментарий

Пожалуйста, войдите, чтобы комментировать.