fbpx
  • slide 1C cloud 3
  • slide microsft
  • slide aida64
  • Нововведения в новой мобильной ОС Android 4.3
  • Скрипт для выгрузки базы 1С в DT
  • Уникальный игровой сервис OnLive
  • Зачем на самом деле нужны встроенные игры в Windows
  • AMD представила первые настольные процессоры с частотой до 5,0 ГГц
  • День системного администратора 2017
  • Супер Wi-Fi на iPhone 5 :)
  • XCOM Enemy Unknown (2012)
  • Анонсирован ОС Android 4.4 KitKat
  • Assassin's Creed 4: Black Flag. Преимущества игр нового поколения.
  • 3DMark 1.0 (2013)
  • Раздача интернета через Wi-Fi
  • Как загрузить Windows 8.1/10 в безопасном режиме
  • Dirt Rally будет работает на Linux
  • Не запускается Pinnacle Studio 16 на Windows 8.1
  • Вывод изображения их Хранилища Значений на форму
  • Что такое UEFI
  • Как сделать перчатки сенсорными
  • Печать табличного документа через общую форму печати в УНФ
  • Borderlands 2 заработал на Windows 8
  • Увеличение размера виртуального и системного диска в Windows Server без остановки VMWare
  • Создание внешней печатной формы по стандарту БСП (тонкий клиент)
  • Изменения правил для приложений в Google Play
  • Что такое интернет
  • Заправка МФУ :)
  • Зачем нужна кнопка
  • Обзор бесплатных антивирусов
июнь20

Свернуть массив в 1С

Троцкий Юрий

Свернуть массив в 1С

Один из вариантов решения свертки массива в 1С.

толстый клиент, тонкий клиент

 

   т.к. в 1С еще пока нет встроенной функции или процедуры по сворачиванию массива, предлагаю вам один из вариантов решения этой задачи.

     Из особенностей работы этого кода - он не будет суммировать значения (как работает свертка в таблице значений), в большей степени он больше работает как фильтр от повторяющихся значений. 


Фунцкция СвернутьМассив (МойМассивДляСвертки)

НовыйМассив = Новый Массив; Соответствие = Новый Соответствие; Для каждого ЭлементМассива Из МойМассивДляСвертки Цикл Соответствие.Вставить(ЭлементМассива); КонецЦикла; Для каждого КлючИЗначение Из Соответствие Цикл НовыйМассив.Добавить(КлючИЗначение.Значение); КонецЦикла; Возврат НовыйМассив; КонецФункции

P.S. Так-же мы предоставлям надежное обланое хранилище для ваших баз 1С. Подробнее...

Оставить комментарий

Пожалуйста, войдите, чтобы комментировать.