fbpx
  • slide 1C cloud 3
  • slide microsft
  • slide aida64
  • Увеличение размера виртуального и системного диска в Windows Server без остановки VMWare
  • Вышла VMware vSphere 6.5
  • Сравнение графики PC и PS4 на новом движке Unreal Engine 4
  • Восстановление разделов на USB флешке
  • Названа дата выхода Windows 10
  • Pinnacle и телепатический модуль
  • В Steam появилась возможность трансляции (Broadcast)
  • Рейтинги защиты IP
  • Как начать вести учет в малом бизнесе ?
  • Дергается курсор мышки в Windows 7. Решение
  • Бездонный телефон
  • Доступ к рабочему столу пользователя Windows из 1С
  • Проблема при обновлении Kubuntu 11.10 desktop x86
  • Первое впечатление о Windows 8 Beta
  • У iPhone больше уязвимостей, чем у всех остальных.
  • Настройка и подключение Wi-Fi роутера D-Link DIR300
  • Ролик про Крым
  • PDFZilla. Конвертор из PDF в Word.
  • Впечатляющая демонстрация Epic Unreal Engine 4
  • Windows Server 2016 доступна
  • Одна из первых реклам Microsoft
  • Секретарша и лист
  • Тест производительности сервера DELL PowerEdge R210 II
  • Как качать с торрента
  • Как сделать перчатки сенсорными
  • День системного администратора
  • Домашний медиа-сервер своими руками. Часть 1
июнь20

Свернуть массив в 1С

Троцкий Юрий

Свернуть массив в 1С

Один из вариантов решения свертки массива в 1С.

толстый клиент, тонкий клиент

 

   т.к. в 1С еще пока нет встроенной функции или процедуры по сворачиванию массива, предлагаю вам один из вариантов решения этой задачи.

     Из особенностей работы этого кода - он не будет суммировать значения (как работает свертка в таблице значений), в большей степени он больше работает как фильтр от повторяющихся значений. 


Фунцкция СвернутьМассив (МойМассивДляСвертки)

НовыйМассив = Новый Массив; Соответствие = Новый Соответствие; Для каждого ЭлементМассива Из МойМассивДляСвертки Цикл Соответствие.Вставить(ЭлементМассива); КонецЦикла; Для каждого КлючИЗначение Из Соответствие Цикл НовыйМассив.Добавить(КлючИЗначение.Значение); КонецЦикла; Возврат НовыйМассив; КонецФункции

P.S. Так-же мы предоставлям надежное обланое хранилище для ваших баз 1С. Подробнее...

Оставить комментарий

Пожалуйста, войдите, чтобы комментировать.