fbpx
  • slide 1C cloud 3
  • slide microsft
  • slide aida64
  • Установка стандартного набора Windows шрифтов в Linux
  • Вышла VMware vSphere 6.5
  • Google Chrome научится воспроизводить FLAC
  • Функция хеширования (конвертирования) строки в MD5 для 1С
  • Dj Tro - For my sole love [2002]
  • S.M.A.R.T. под VMware vSphere
  • Assassin's Creed 4: Black Flag. Преимущества игр нового поколения.
  • Вывод изображения их Хранилища Значений на форму
  • Семь мифов о сисадминах
  • Обзор игры EVE Online
  • Сервис VirusTotal и его возможности
  • Свич или магнитофон ?
  • Microsoft прекращает развитие графического редактора Paint
  • День системного администратора 2019
  • Один из старейших компьютеров WITCH продолжает работать.
  • Беспроводная зарядка в телефоне, где ее быть не должно :)
  • Названа дата выхода Windows 10
  • Создание своего Ubuntu Live CD
  • Релиз KDE 4.8
  • Чумной барак для сумасшедших фриков
  • Новый 3D алгоритм симуляции воды
  • Хостинг вашей 1С в облаке
  • Заправка МФУ :)
  • Dj Tro - Just a fool [2011]
  • Раздача интернета через Wi-Fi
  • Dirt Rally будет работает на Linux
  • Что, еще и место выбирать ?!
июнь20

Свернуть массив в 1С

Троцкий Юрий

Свернуть массив в 1С

Один из вариантов решения свертки массива в 1С.

толстый клиент, тонкий клиент

 

   т.к. в 1С еще пока нет встроенной функции или процедуры по сворачиванию массива, предлагаю вам один из вариантов решения этой задачи.

     Из особенностей работы этого кода - он не будет суммировать значения (как работает свертка в таблице значений), в большей степени он больше работает как фильтр от повторяющихся значений. 


Фунцкция СвернутьМассив (МойМассивДляСвертки)

НовыйМассив = Новый Массив; Соответствие = Новый Соответствие; Для каждого ЭлементМассива Из МойМассивДляСвертки Цикл Соответствие.Вставить(ЭлементМассива); КонецЦикла; Для каждого КлючИЗначение Из Соответствие Цикл НовыйМассив.Добавить(КлючИЗначение.Значение); КонецЦикла; Возврат НовыйМассив; КонецФункции

P.S. Так-же мы предоставлям надежное обланое хранилище для ваших баз 1С. Подробнее...

Оставить комментарий

Пожалуйста, войдите, чтобы комментировать.