fbpx
  • slide 1C cloud 3
  • slide microsft
  • slide aida64
  • День компьютерщика
  • Как говорить с техподдержкой
  • Сюжетный трейлер Mortal Kombat X
  • В России ФСБ добивается полного доступа к данным интернет-пользователей
  • C Днем Системного Администратора !
  • Microsoft прекращает развитие графического редактора Paint
  • Что, еще и место выбирать ?!
  • Sandboxie. Работаем в
  • Звездочки
  • Одна из первых реклам Microsoft
  • Что такое интернет
  • 3DMark 1.0 (2013)
  • Перенос контактов с WinMobile на Android и не только
  • Windows Server 2016 доступна
  • Активация Windows 8 v.2
  • Домашний медиа-сервер своими руками. Часть 1
  • Принтер с бонусом внутри :)
  • С Днем Программиста 2012
  • Печать табличного документа через общую форму печати в УНФ
  • Серверные процессоры нового поколения Intel Xeon E7 v2
  • Почему-то камеры постоянно глючат
  • Обзор телефона Sony Ericsson Zylo
  • 5 неудачных антипиратских решений
  • Обзор бесплатных антивирусов
  • Секретарша и лист
  • Использование LiveCD для восстановления пароля суперпользователя root в Linux
  • Ошибка 0x8000000000000002. Решение.
июнь20

Свернуть массив в 1С

Троцкий Юрий

Свернуть массив в 1С

Один из вариантов решения свертки массива в 1С.

толстый клиент, тонкий клиент

 

   т.к. в 1С еще пока нет встроенной функции или процедуры по сворачиванию массива, предлагаю вам один из вариантов решения этой задачи.

     Из особенностей работы этого кода - он не будет суммировать значения (как работает свертка в таблице значений), в большей степени он больше работает как фильтр от повторяющихся значений. 


Фунцкция СвернутьМассив (МойМассивДляСвертки)

НовыйМассив = Новый Массив; Соответствие = Новый Соответствие; Для каждого ЭлементМассива Из МойМассивДляСвертки Цикл Соответствие.Вставить(ЭлементМассива); КонецЦикла; Для каждого КлючИЗначение Из Соответствие Цикл НовыйМассив.Добавить(КлючИЗначение.Значение); КонецЦикла; Возврат НовыйМассив; КонецФункции

Оставить комментарий

Пожалуйста, войдите, чтобы комментировать.