fbpx
  • slide 1C cloud 3
  • slide microsft
  • slide aida64
  • Активация Windows 8 v.2
  • Dj Tro - Just a fool [2011]
  • Zalman начала процедуру банкротства
  • Что означают тесты в AIDA64
  • XCOM Enemy Unknown (2012)
  • Падение сервера 1С после переименования компьютера
  • Pinnacle и телепатический модуль
  • Иван Царевич,DjTro - Сталь манит кровь
  • Функция хеширования (конвертирования) строки в MD5 для 1С
  • Borderlands 2 заработал на Windows 8
  • DirectX 11.2 был показан в Windows 8.1
  • Как отключить легкую установку (easy install) в VMWare Workstation
  • Российская Госдума приняла закон о блокировке сайтов с пиратскими фильмами
  • Тест супер-кулера Noctua NH-D14
  • Как качать с торрента
  • Сброс пароля пользователя на MacOS
  • Восстановление разделов на USB флешке
  • Скрипт установки принтеров Canon LBP на Linux Ubuntu (обновлено)
  • Печать табличного документа через общую форму печати в УНФ
  • Изменения правил для приложений в Google Play
  • Windows 9
  • Сравнение графики PC и PS4 на новом движке Unreal Engine 4
  • Беспроводная зарядка в телефоне, где ее быть не должно :)
  • С Днем Программиста 2017
  • Сюжетный трейлер Mortal Kombat X
  • Облачное хранилище Hive прекращает деятельность
  • Автозагрузка в Windows 10
июнь20

Свернуть массив в 1С

Троцкий Юрий

Свернуть массив в 1С

Один из вариантов решения свертки массива в 1С.

толстый клиент, тонкий клиент

 

   т.к. в 1С еще пока нет встроенной функции или процедуры по сворачиванию массива, предлагаю вам один из вариантов решения этой задачи.

     Из особенностей работы этого кода - он не будет суммировать значения (как работает свертка в таблице значений), в большей степени он больше работает как фильтр от повторяющихся значений. 


Фунцкция СвернутьМассив (МойМассивДляСвертки)

НовыйМассив = Новый Массив; Соответствие = Новый Соответствие; Для каждого ЭлементМассива Из МойМассивДляСвертки Цикл Соответствие.Вставить(ЭлементМассива); КонецЦикла; Для каждого КлючИЗначение Из Соответствие Цикл НовыйМассив.Добавить(КлючИЗначение.Значение); КонецЦикла; Возврат НовыйМассив; КонецФункции

Оставить комментарий

Пожалуйста, войдите, чтобы комментировать.