fbpx
  • slide 1C cloud 3
  • slide microsft
  • slide aida64
  • Свет увидел ролик грядущего DOOM4
  • Что нас ждет в грядущих драйверах NVidia 300.**
  • Zalman начала процедуру банкротства
  • Вышла VMware vSphere 6.5
  • Чумной барак для сумасшедших фриков
  • Скрипт установки принтеров Canon LBP на Linux Ubuntu (обновлено)
  • Assassin's Creed 4: Black Flag. Преимущества игр нового поколения.
  • Как загрузить Windows 8.1/10 в безопасном режиме
  • Супер Wi-Fi на iPhone 5 :)
  • Microsoft Windows 8.1 Preview доступен для бесплатного скачивания
  • Решение ATI Radeon HD3000/4000 Overscan/Underscan
  • Lineage OS не будет предоставлять пользователям root-права
  • Установка драйвера ATI Radeon 9000 на Windows 7
  • Dj TRO  vs Dj Celeron - Atomix Wars [2003]
  • online эмулятор Windows 1.01
  • Серверные процессоры нового поколения Intel Xeon E7 v2
  • Увеличить ТИЦ
  • Беспроводная зарядка в телефоне, где ее быть не должно :)
  • Вход под Администратором на Windows XP
  • Что такое UEFI
  • Создание загрузочной/установочной USB-Флешки c Linux
  • Неожиданный предмет внутри коробки с монитором AOC F22+
  • Два диска
  • Свернуть массив в 1С
  • Dj Tro - For my sole love [2002]
  • Как сделать перчатки сенсорными
  • Как отключить легкую установку (easy install) в VMWare Workstation
июнь20

Свернуть массив в 1С

Троцкий Юрий

Свернуть массив в 1С

Один из вариантов решения свертки массива в 1С.

толстый клиент, тонкий клиент

 

   т.к. в 1С еще пока нет встроенной функции или процедуры по сворачиванию массива, предлагаю вам один из вариантов решения этой задачи.

     Из особенностей работы этого кода - он не будет суммировать значения (как работает свертка в таблице значений), в большей степени он больше работает как фильтр от повторяющихся значений. 


Фунцкция СвернутьМассив (МойМассивДляСвертки)

НовыйМассив = Новый Массив; Соответствие = Новый Соответствие; Для каждого ЭлементМассива Из МойМассивДляСвертки Цикл Соответствие.Вставить(ЭлементМассива); КонецЦикла; Для каждого КлючИЗначение Из Соответствие Цикл НовыйМассив.Добавить(КлючИЗначение.Значение); КонецЦикла; Возврат НовыйМассив; КонецФункции

Оставить комментарий

Пожалуйста, войдите, чтобы комментировать.