fbpx
  • услуги хостинга 1С в облаке
  • slide microsft
  • slide aida64
  • Сравнение графики PC и PS4 на новом движке Unreal Engine 4
  • Китайцы назвали WINDOWS 8 угрозой для страны
  • Warframe. Или как закалялась сталь.
  • Как скрыть файлы в Linux MINT
  • Основные команды в Linux
  • Создание загрузочной/установочной USB-Флешки c Linux
  • Windows 8.1 вышла в свет
  • Оптимизация запуска приложений в Linux
  • Как отключить легкую установку (easy install) в VMWare Workstation
  • Умер Ральф Баер, родитель игровых консолей
  • Печать табличного документа через общую форму печати в УНФ
  • online эмулятор Windows 1.01
  • Названа дата выхода Windows 10
  • Как качать с торрента
  • Сюжетный трейлер Mortal Kombat X
  • Анонсирован ОС Android 4.4 KitKat
  • Ошибка 0x8000000000000002. Решение.
  • Как говорить с техподдержкой
  • Доступ к рабочему столу пользователя Windows из 1С
  • Windows Server 2016 доступна
  • Один из старейших компьютеров WITCH продолжает работать.
  • Лучший тест стабильности ПК - Prime95
  • Релиз KDE 4.8
  • Беспроводная зарядка в телефоне, где ее быть не должно :)
  • Что такое интернет
  • Новое на сайте tro.net.ua
  • Sandboxie. Работаем в
июнь20

Свернуть массив в 1С

Троцкий Юрий

Свернуть массив в 1С

Один из вариантов решения свертки массива в 1С.

толстый клиент, тонкий клиент

 

   т.к. в 1С еще пока нет встроенной функции или процедуры по сворачиванию массива, предлагаю вам один из вариантов решения этой задачи.

     Из особенностей работы этого кода - он не будет суммировать значения (как работает свертка в таблице значений), в большей степени он больше работает как фильтр от повторяющихся значений. 


Фунцкция СвернутьМассив (МойМассивДляСвертки)

НовыйМассив = Новый Массив; Соответствие = Новый Соответствие; Для каждого ЭлементМассива Из МойМассивДляСвертки Цикл Соответствие.Вставить(ЭлементМассива); КонецЦикла; Для каждого КлючИЗначение Из Соответствие Цикл НовыйМассив.Добавить(КлючИЗначение.Значение); КонецЦикла; Возврат НовыйМассив; КонецФункции

Оставить комментарий

Пожалуйста, войдите, чтобы комментировать.