fbpx
  • slide 1C cloud 3
  • slide microsft
  • slide aida64
  • Свет увидел ролик грядущего DOOM4
  • С днем системного администратора !
  • Анонсирован ОС Android 4.4 KitKat
  • На сайте открыт магазин
  • SDI - все драйвера в одном пакете
  • Как сделать перчатки сенсорными
  • Использование LiveCD для восстановления пароля суперпользователя root в Linux
  • Игрушка вертолет Angry Birds
  • Один из старейших компьютеров WITCH продолжает работать.
  • Как отключить надпись
  • Adobe Creative Suite 6
  • Ролик про Крым
  • Одна из первых реклам Microsoft
  • Грядущий новый формат изображений от Google
  • Запуск VMWare ESXi Customizer на несовместимой ОС
  • Тест супер-кулера Noctua NH-D14
  • Уникальный игровой сервис OnLive
  • Звездочки
  • Иван Царевич,Dj Tro - Твой свет
  • Вышла VMware vSphere 6.5
  • Как качать с торрента
  • Дергается курсор мышки в Windows 7. Решение
  • 3D контент на картах NVidia без 3D Vision
  • Новый Adobe Photoshop CC взломан через день после релиза
  • Восстановление разделов на USB флешке
  • Автозагрузка в Windows 10
  • Сюжетный трейлер Mortal Kombat X
июнь20

Свернуть массив в 1С

Троцкий Юрий

Свернуть массив в 1С

Один из вариантов решения свертки массива в 1С.

толстый клиент, тонкий клиент

 

   т.к. в 1С еще пока нет встроенной функции или процедуры по сворачиванию массива, предлагаю вам один из вариантов решения этой задачи.

     Из особенностей работы этого кода - он не будет суммировать значения (как работает свертка в таблице значений), в большей степени он больше работает как фильтр от повторяющихся значений. 


Фунцкция СвернутьМассив (МойМассивДляСвертки)

НовыйМассив = Новый Массив; Соответствие = Новый Соответствие; Для каждого ЭлементМассива Из МойМассивДляСвертки Цикл Соответствие.Вставить(ЭлементМассива); КонецЦикла; Для каждого КлючИЗначение Из Соответствие Цикл НовыйМассив.Добавить(КлючИЗначение.Значение); КонецЦикла; Возврат НовыйМассив; КонецФункции

P.S. Так-же мы предоставлям надежное обланое хранилище для ваших баз 1С. Подробнее...

Оставить комментарий

Пожалуйста, войдите, чтобы комментировать.