fbpx
  • slide 1C cloud 3
  • slide microsft
  • slide aida64
  • Анонсирован Mortal Kombat X
  • С днем системного администратора !
  • Dj TRO  vs Dj Celeron - Atomix Wars [2003]
  • Бездонный телефон
  • Автозагрузка в Windows 10
  • Как загрузить Windows 8.1/10 в безопасном режиме
  • День системного администратора 2017
  • Секретарша и лист
  • Обзор бесплатных антивирусов
  • Установка стандартного набора Windows шрифтов в Linux
  • Бесплатные звонки с VIBER
  • Сюжетный трейлер Mortal Kombat X
  • Windows Server 2016 доступна
  • Как отключить тачпад ноутбука в Linux Ubuntu
  • Что такое UEFI
  • Вывод изображения их Хранилища Значений на форму
  • Релиз KDE 4.8
  • Сброс пароля пользователя на MacOS
  • День компьютерщика
  • Лучший тест стабильности ПК - Prime95
  • NVIDIA представила технологию симуляции и рендеринга реалистичной травы - TurfEffects
  • Старый новый
  • Движок Unreal Engine 4 переедет на HTML5
  • Настройка и подключение Wi-Fi роутера D-Link DIR300
  • 3DMark 1.0 (2013)
  • Увеличить ТИЦ
  • C Днем Системного Администратора !
июнь20

Свернуть массив в 1С

Троцкий Юрий

Свернуть массив в 1С

Один из вариантов решения свертки массива в 1С.

толстый клиент, тонкий клиент

 

   т.к. в 1С еще пока нет встроенной функции или процедуры по сворачиванию массива, предлагаю вам один из вариантов решения этой задачи.

     Из особенностей работы этого кода - он не будет суммировать значения (как работает свертка в таблице значений), в большей степени он больше работает как фильтр от повторяющихся значений. 


Фунцкция СвернутьМассив (МойМассивДляСвертки)

НовыйМассив = Новый Массив; Соответствие = Новый Соответствие; Для каждого ЭлементМассива Из МойМассивДляСвертки Цикл Соответствие.Вставить(ЭлементМассива); КонецЦикла; Для каждого КлючИЗначение Из Соответствие Цикл НовыйМассив.Добавить(КлючИЗначение.Значение); КонецЦикла; Возврат НовыйМассив; КонецФункции

P.S. Так-же мы предоставлям надежное обланое хранилище для ваших баз 1С. Подробнее...

Оставить комментарий

Пожалуйста, войдите, чтобы комментировать.