fbpx
  • slide 1C cloud 3
  • slide microsft
  • slide aida64
  • Как загрузить Windows 8.1/10 в безопасном режиме
  • Установка Apple TrackPad на Windows
  • Установка драйвера ATI Radeon 9000 на Windows 7
  • Бесплатное безграничное облачное хранилище Hive
  • DirectX 11.2 был показан в Windows 8.1
  • Dirt Rally будет работает на Linux
  • Падение сервера 1С после переименования компьютера
  • Рейтинги защиты IP
  • Сервис VirusTotal и его возможности
  • Настройка и подключение Wi-Fi роутера D-Link DIR300
  • Анлок и джеилбрейк 3.1.2 на iPhone 2G/3G/3GS из-под Windows
  • Звездочки
  • Супер Wi-Fi на iPhone 5 :)
  • Dj Tro - TO [2008]
  • Прошивка MAC-адресса в интегрированной сетевой карте
  • C Днем Системного Администратора !
  • Вход под Администратором на Windows XP
  • Создание загрузочной/установочной USB-Флешки c Linux
  • Автоматический вход в Windows без ввода пароля
  • Сброс пароля пользователя на MacOS
  • Apple лишает работоспособности iPhone и iPad после неофициального ремонта
  • Запуск VMWare ESXi Customizer на несовместимой ОС
  • Ролик про Крым
  • S.M.A.R.T. под VMware vSphere
  • Драйвера Nvidia 296.10
  • Как качать с торрента
  • С Днем Программиста 2017
мая23

Печать табличного документа через общую форму печати в УНФ

Троцкий Юрий

Печать табличного документа через общую форму печати в УНФ

Применение встроенного механизма печати в 1С УНФ для печати своего табличного документа.

тонкий клиент

 

 

1. На форме, где должны быть кнопка печати, создаем группу типа "Подменю" (или командную группу) где будет размещаться кнпка печати.

2. Создаем программно кнопку, по нажатию которой должен печататься Табличный документ в модуле формы ПриСозданииНаСервере

 &НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	УправлениеПечатью.ПриСозданииНаСервере(ЭтаФорма, Элементы.КомандыПечать);	
КонецПроцедуры 

3. МодульФормы документа. Обработчик нажатия программно созданной кнопки

&НаКлиенте
Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)
	УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтотОбъект, Объект);
КонецПроцедуры

4. Модуль менеджера документа.

Процедура ДобавитьКомандыПечати(КомандыПечати) Экспорт
// Расшифровка платежа
КомандаПечати = КомандыПечати.Добавить();
КомандаПечати.Идентификатор = "МакетРасшифровкаПлатежа";
КомандаПечати.Представление = НСтр("ru = 'Расшифровка платежа'");
КомандаПечати.СписокФорм = "ФормаДокумента,ФормаСписка";
КомандаПечати.ПроверкаПроведенияПередПечатью = Ложь;
КомандаПечати.ПереопределитьПользовательскиеНастройкиКоличества = Истина;
КомандаПечати.МестоРазмещения = "КомандыПечать";
КомандаПечати.Порядок = 1;			
КонецПроцедуры
Процедура Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
	
ПараметрыВывода.ДоступнаПечатьПоКомплектно = Ложь;

Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "МакетРасшифровкаПлатежа") Тогда		
		УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "МакетРасшифровкаПлатежа", "Расшифровка платежа", ПечатнаяФорма(МассивОбъектов, ОбъектыПечати, "МакетРасшифровкаПлатежа"));
КонецЕсли;
	
//Параметры отправки печатных форм по электронной почте
УправлениеНебольшойФирмойСервер.ЗаполнитьПараметрыОтправки(ПараметрыВывода.ПараметрыОтправки, МассивОбъектов, КоллекцияПечатныхФорм);
КонецПроцедуры
Функция ПечатнаяФорма(МассивОбъектов, ОбъектыПечати, ИмяМакета)
Если ИмяМакета = "МакетРасшифровкаПлатежа" Тогда		
		Возврат ПечатьРасшифровкаПлатежа(МассивОбъектов, ОбъектыПечати, ИмяМакета);
КонецЕсли;
КонецФункции
Функция ПечатьРасшифровкаПлатежа(МассивОбъектов,ОбъектыПечати,ИмяМакета) Экспорт 
	
	ПервыйДокумент		=	Истина;
	ТабличныйДокумент	=	Новый ТабличныйДокумент;
	Макет	=	ПолучитьМакет("МакетРасшифровкаПлатежа");
	
	Для Каждого Документ из МассивОбъектов Цикл 
	
	//Текст формирования табличного документа	
	
	ПервыйДокумент	= Ложь;
КонецЦикла;


ТабличныйДокумент.АвтоМасштаб = Истина;
Возврат ТабличныйДокумент;	

КонецФункции

P.S. Так-же мы предоставлям надежное обланое хранилище для ваших баз 1С. Подробнее...

Оставить комментарий

Пожалуйста, войдите, чтобы комментировать.