fbpx
  • slide 1C cloud 3
  • slide microsft
  • slide aida64
  • Печать табличного документа через общую форму печати в УНФ
  • Немного о глобальных аватарах
  • День компьютерщика
  • С Днем системного администратора !!!
  • Свет в конце тоннеля для игр на Linux
  • 3DMark 1.0 (2013)
  • Warframe. Или как закалялась сталь.
  • Перенос контактов с WinMobile на Android и не только
  • Неожиданный предмет внутри коробки с монитором AOC F22+
  • NVIDIA представила технологию симуляции и рендеринга реалистичной травы - TurfEffects
  • Обзор эволюции ОС Microsoft Windows
  • Свернуть массив в 1С
  • Borderlands 2 заработал на Windows 8
  • С Днем Программиста 2017
  • Стал тормозить SSD ? А у вас есть trim ?
  • Apple лишает работоспособности iPhone и iPad после неофициального ремонта
  • Как начать вести учет в малом бизнесе ?
  • Бесплатные звонки с VIBER
  • Поднимаем FPS в играх в Windows 10
  • Восстановление разделов на USB флешке
  • Ошибка 0x8000000000000002. Решение.
  • Беспроводная зарядка в телефоне, где ее быть не должно :)
  • Создание внешней печатной формы по стандарту БСП (тонкий клиент)
  • Dirt Rally будет работает на Linux
  • Сравнение графики PC и PS4 на новом движке Unreal Engine 4
  • Анонсирован Mortal Kombat X
  • Скрипт установки принтеров Canon LBP на Linux Ubuntu (обновлено)
мая23

Печать табличного документа через общую форму печати в УНФ

Троцкий Юрий

Печать табличного документа через общую форму печати в УНФ

Применение встроенного механизма печати в 1С УНФ для печати своего табличного документа.

тонкий клиент

 

 

1. На форме, где должны быть кнопка печати, создаем группу типа "Подменю" (или командную группу) где будет размещаться кнпка печати.

2. Создаем программно кнопку, по нажатию которой должен печататься Табличный документ в модуле формы ПриСозданииНаСервере

 &НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	УправлениеПечатью.ПриСозданииНаСервере(ЭтаФорма, Элементы.КомандыПечать);	
КонецПроцедуры 

3. МодульФормы документа. Обработчик нажатия программно созданной кнопки

&НаКлиенте
Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)
	УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтотОбъект, Объект);
КонецПроцедуры

4. Модуль менеджера документа.

Процедура ДобавитьКомандыПечати(КомандыПечати) Экспорт
// Расшифровка платежа
КомандаПечати = КомандыПечати.Добавить();
КомандаПечати.Идентификатор = "МакетРасшифровкаПлатежа";
КомандаПечати.Представление = НСтр("ru = 'Расшифровка платежа'");
КомандаПечати.СписокФорм = "ФормаДокумента,ФормаСписка";
КомандаПечати.ПроверкаПроведенияПередПечатью = Ложь;
КомандаПечати.ПереопределитьПользовательскиеНастройкиКоличества = Истина;
КомандаПечати.МестоРазмещения = "КомандыПечать";
КомандаПечати.Порядок = 1;			
КонецПроцедуры
Процедура Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
	
ПараметрыВывода.ДоступнаПечатьПоКомплектно = Ложь;

Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "МакетРасшифровкаПлатежа") Тогда		
		УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "МакетРасшифровкаПлатежа", "Расшифровка платежа", ПечатнаяФорма(МассивОбъектов, ОбъектыПечати, "МакетРасшифровкаПлатежа"));
КонецЕсли;
	
//Параметры отправки печатных форм по электронной почте
УправлениеНебольшойФирмойСервер.ЗаполнитьПараметрыОтправки(ПараметрыВывода.ПараметрыОтправки, МассивОбъектов, КоллекцияПечатныхФорм);
КонецПроцедуры
Функция ПечатнаяФорма(МассивОбъектов, ОбъектыПечати, ИмяМакета)
Если ИмяМакета = "МакетРасшифровкаПлатежа" Тогда		
		Возврат ПечатьРасшифровкаПлатежа(МассивОбъектов, ОбъектыПечати, ИмяМакета);
КонецЕсли;
КонецФункции
Функция ПечатьРасшифровкаПлатежа(МассивОбъектов,ОбъектыПечати,ИмяМакета) Экспорт 
	
	ПервыйДокумент		=	Истина;
	ТабличныйДокумент	=	Новый ТабличныйДокумент;
	Макет	=	ПолучитьМакет("МакетРасшифровкаПлатежа");
	
	Для Каждого Документ из МассивОбъектов Цикл 
	
	//Текст формирования табличного документа	
	
	ПервыйДокумент	= Ложь;
КонецЦикла;


ТабличныйДокумент.АвтоМасштаб = Истина;
Возврат ТабличныйДокумент;	

КонецФункции

P.S. Так-же мы предоставлям надежное обланое хранилище для ваших баз 1С. Подробнее...

Оставить комментарий

Пожалуйста, войдите, чтобы комментировать.