fbpx
  • услуги хостинга 1С в облаке
  • slide microsft
  • slide aida64
  • Dj Tro - TO [2008]
  • Переведем ваш 1С на наше облачное хранилище
  • Вышло одно из самых ожидаемых дополнений к Mortal Kombat X
  • Автоматический вход в Windows без ввода пароля
  • Dj Tro - The new trance [2013]
  • Раздача интернета через Wi-Fi
  • День компьютерщика
  • Медленная скорость Интернет/RDP соединения Windows
  • Игрушка вертолет Angry Birds
  • Dj Tro - Just a fool [2011]
  • Dirt Rally будет работает на Linux
  • Серверные процессоры нового поколения Intel Xeon E7 v2
  • Активация Windows 8 v.2
  • Автозагрузка в Windows 10
  • OneWeb - глобальный проект интернет доступа
  • Ошибка 0x8000000000000002. Решение.
  • GeForce Experience
  • Свет в конце тоннеля для игр на Linux
  • Sandboxie. Работаем в
  • Семь мифов о сисадминах
  • Новый Adobe Photoshop CC взломан через день после релиза
  • Названа дата выхода Windows 10
  • Завершение процессов на удаленном компьютере Windows
  • Pinnacle и телепатический модуль
  • Как отключить тачпад ноутбука в Linux Ubuntu
  • Как говорить с техподдержкой
  • Google Chrome научится воспроизводить FLAC
июнь20

Свернуть массив в 1С

Троцкий Юрий

Свернуть массив в 1С

Один из вариантов решения свертки массива в 1С.

толстый клиент, тонкий клиент

 

   т.к. в 1С еще пока нет встроенной функции или процедуры по сворачиванию массива, предлагаю вам один из вариантов решения этой задачи.

     Из особенностей работы этого кода - он не будет суммировать значения (как работает свертка в таблице значений), в большей степени он больше работает как фильтр от повторяющихся значений. 


Фунцкция СвернутьМассив (МойМассивДляСвертки)

НовыйМассив = Новый Массив; Соответствие = Новый Соответствие; Для каждого ЭлементМассива Из МойМассивДляСвертки Цикл Соответствие.Вставить(ЭлементМассива); КонецЦикла; Для каждого КлючИЗначение Из Соответствие Цикл НовыйМассив.Добавить(КлючИЗначение.Значение); КонецЦикла; Возврат НовыйМассив; КонецФункции

Оставить комментарий

Пожалуйста, войдите, чтобы комментировать.