fbpx
  • slide 1C cloud 3
  • slide microsft
  • slide aida64
  • Секретарша и лист
  • У iPhone больше уязвимостей, чем у всех остальных.
  • Обзор бесплатных антивирусов
  • Зачем на самом деле нужны встроенные игры в Windows
  • Sandboxie. Работаем в
  • PDFZilla. Конвертор из PDF в Word.
  • Apple лишает работоспособности iPhone и iPad после неофициального ремонта
  • Дергается курсор мышки в Windows 7. Решение
  • Обзор игры EVE Online
  • Неожиданный предмет внутри коробки с монитором AOC F22+
  • Активация Windows 8 v.2
  • Dirt Rally будет работает на Linux
  • Разгон, изменение и прошивка BIOS видеокарт Nvidia
  • Как загрузить Windows 8.1/10 в безопасном режиме
  • Создание внешней печатной формы по стандарту БСП (тонкий клиент)
  • В России ФСБ добивается полного доступа к данным интернет-пользователей
  • Обзор телефона Sony Ericsson Zylo
  • Активация Windows 8
  • Грядущий новый формат изображений от Google
  • Что такое интернет
  • Российские операторы сотовой связи отказались от продаж iPhone
  • Настройка и подключение Wi-Fi роутера D-Link DIR300
  • Переведем ваш 1С на наше облачное хранилище
  • Одна из первых реклам Microsoft
  • Облачное хранилище Hive прекращает деятельность
  • Ролик про Крым
  • С днем системного администратора !
июнь20

Свернуть массив в 1С

Троцкий Юрий

Свернуть массив в 1С

Один из вариантов решения свертки массива в 1С.

толстый клиент, тонкий клиент

 

   т.к. в 1С еще пока нет встроенной функции или процедуры по сворачиванию массива, предлагаю вам один из вариантов решения этой задачи.

     Из особенностей работы этого кода - он не будет суммировать значения (как работает свертка в таблице значений), в большей степени он больше работает как фильтр от повторяющихся значений. 


Фунцкция СвернутьМассив (МойМассивДляСвертки)

НовыйМассив = Новый Массив; Соответствие = Новый Соответствие; Для каждого ЭлементМассива Из МойМассивДляСвертки Цикл Соответствие.Вставить(ЭлементМассива); КонецЦикла; Для каждого КлючИЗначение Из Соответствие Цикл НовыйМассив.Добавить(КлючИЗначение.Значение); КонецЦикла; Возврат НовыйМассив; КонецФункции

P.S. Так-же мы предоставлям надежное обланое хранилище для ваших баз 1С. Подробнее...

Оставить комментарий

Пожалуйста, войдите, чтобы комментировать.