fbpx
  • slide 1C cloud 3
  • slide microsft
  • slide aida64
  • Как скрыть файлы в Linux MINT
  • Поднимаем FPS в играх в Windows 10
  • PDFZilla. Конвертор из PDF в Word.
  • Вышло одно из самых ожидаемых дополнений к Mortal Kombat X
  • Разблокировка функции DSR в драйверах Nvidia для старых карт
  • Новое на сайте tro.net.ua
  • Анонсирован Mortal Kombat X
  • Как отключить легкую установку (easy install) в VMWare Workstation
  • SDI - все драйвера в одном пакете
  • С Днем Программиста 2017
  • Одна из первых реклам Microsoft
  • Запуск VMWare ESXi Customizer на несовместимой ОС
  • Microsoft прекращает развитие графического редактора Paint
  • Свои подсказки для передаваемых параметров
  • Впечатляющая демонстрация Epic Unreal Engine 4
  • Домашний медиа-сервер своими руками. Часть 1
  • Как качать с торрента
  • Google Chrome научится воспроизводить FLAC
  • Создаем свой караоке-видео
  • Сюжетный трейлер Mortal Kombat X
  • Лучший тест стабильности ПК - Prime95
  • DirectX 11.2 был показан в Windows 8.1
  • Вышел в свет Windows 8.1
  • Неожиданный предмет внутри коробки с монитором AOC F22+
  • Как отключить тачпад ноутбука в Linux Ubuntu
  • Windows 8.1 вышла в свет
  • Хостинг вашей 1С в облаке
июнь20

Свернуть массив в 1С

Троцкий Юрий

Свернуть массив в 1С

Один из вариантов решения свертки массива в 1С.

толстый клиент, тонкий клиент

 

   т.к. в 1С еще пока нет встроенной функции или процедуры по сворачиванию массива, предлагаю вам один из вариантов решения этой задачи.

     Из особенностей работы этого кода - он не будет суммировать значения (как работает свертка в таблице значений), в большей степени он больше работает как фильтр от повторяющихся значений. 


Фунцкция СвернутьМассив (МойМассивДляСвертки)

НовыйМассив = Новый Массив; Соответствие = Новый Соответствие; Для каждого ЭлементМассива Из МойМассивДляСвертки Цикл Соответствие.Вставить(ЭлементМассива); КонецЦикла; Для каждого КлючИЗначение Из Соответствие Цикл НовыйМассив.Добавить(КлючИЗначение.Значение); КонецЦикла; Возврат НовыйМассив; КонецФункции

Оставить комментарий

Пожалуйста, войдите, чтобы комментировать.