fbpx
  • slide 1C cloud 3
  • slide microsft
  • slide aida64
  • Обход пароля на IPad touch
  • Перезагрузка или завершение работы удаленного компьютера с Windows
  • Как начать вести учет в малом бизнесе ?
  • Новый Adobe Photoshop CC взломан через день после релиза
  • Движок Unreal Engine 4 переедет на HTML5
  • Стал тормозить SSD ? А у вас есть trim ?
  • Полноценная ОС для слабых машин
  • Winamp прекращает свое существование
  • Игрушка вертолет Angry Birds
  • Одна из первых реклам Microsoft
  • Pinnacle и телепатический модуль
  • Релиз KDE 4.8
  • Создание загрузочной Windows USB-флешки
  • Что нас ждет в грядущих драйверах NVidia 300.**
  • Установка драйвера ATI Radeon 9000 на Windows 7
  • Домашний медиа-сервер своими руками. Часть 1
  • Бесплатные звонки с VIBER
  • Google Chrome научится воспроизводить FLAC
  • День компьютерщика
  • Dj Tro - For my sole love [2002]
  • Сброс пароля пользователя на MacOS
  • Заправка МФУ :)
  • Лучший тест стабильности ПК - Prime95
  • Завершение процессов на удаленном компьютере Windows
  • Как обойти экран блокировки в iOS
  • Российские операторы сотовой связи отказались от продаж iPhone
  • Зачем нужна кнопка
июнь20

Свернуть массив в 1С

Троцкий Юрий

Свернуть массив в 1С

Один из вариантов решения свертки массива в 1С.

толстый клиент, тонкий клиент

 

   т.к. в 1С еще пока нет встроенной функции или процедуры по сворачиванию массива, предлагаю вам один из вариантов решения этой задачи.

     Из особенностей работы этого кода - он не будет суммировать значения (как работает свертка в таблице значений), в большей степени он больше работает как фильтр от повторяющихся значений. 


Фунцкция СвернутьМассив (МойМассивДляСвертки)

НовыйМассив = Новый Массив; Соответствие = Новый Соответствие; Для каждого ЭлементМассива Из МойМассивДляСвертки Цикл Соответствие.Вставить(ЭлементМассива); КонецЦикла; Для каждого КлючИЗначение Из Соответствие Цикл НовыйМассив.Добавить(КлючИЗначение.Значение); КонецЦикла; Возврат НовыйМассив; КонецФункции

P.S. Так-же мы предоставлям надежное обланое хранилище для ваших баз 1С. Подробнее...

Оставить комментарий

Пожалуйста, войдите, чтобы комментировать.