fbpx
  • slide 1C cloud 3
  • slide microsft
  • slide aida64
  • Создание своего Ubuntu Live CD
  • DirectX 11.2 был показан в Windows 8.1
  • Бесплатные звонки с VIBER
  • Первое впечатление о Windows 8 Beta
  • GeForce Experience
  • Dj Tro - TO [2008]
  • Открытие формы в режиме выбора с отбором и возвратом выбора в произвольную процедуру (тонкий клиент)
  • Семь мифов о сисадминах
  • Перезагрузка или завершение работы удаленного компьютера с Windows
  • Вышло одно из самых ожидаемых дополнений к Mortal Kombat X
  • Завершение процессов на удаленном компьютере Windows
  • Dj Tro - The new trance [2013]
  • Dj TRO  vs Dj Celeron - Atomix Wars [2003]
  • Увеличение размера виртуального и системного диска в Windows Server без остановки VMWare
  • Обход пароля на IPad touch
  • На сайте открыт магазин
  • Microsoft предлагает заменить маму смартфоном
  • Одна из первых реклам Microsoft
  • Российские операторы сотовой связи отказались от продаж iPhone
  • Мой плановый выходной
  • 3DMark 1.0 (2013)
  • Сброс пароля пользователя на MacOS
  • Увеличить ТИЦ
  • Переведем ваш 1С на наше облачное хранилище
  • Знакомство с Windows 8. Взгляд с близка.
  • Как отключить тачпад ноутбука в Linux Ubuntu
  • Adobe Creative Suite 6
июнь20

Свернуть массив в 1С

Троцкий Юрий

Свернуть массив в 1С

Один из вариантов решения свертки массива в 1С.

толстый клиент, тонкий клиент

 

   т.к. в 1С еще пока нет встроенной функции или процедуры по сворачиванию массива, предлагаю вам один из вариантов решения этой задачи.

     Из особенностей работы этого кода - он не будет суммировать значения (как работает свертка в таблице значений), в большей степени он больше работает как фильтр от повторяющихся значений. 


Фунцкция СвернутьМассив (МойМассивДляСвертки)

НовыйМассив = Новый Массив; Соответствие = Новый Соответствие; Для каждого ЭлементМассива Из МойМассивДляСвертки Цикл Соответствие.Вставить(ЭлементМассива); КонецЦикла; Для каждого КлючИЗначение Из Соответствие Цикл НовыйМассив.Добавить(КлючИЗначение.Значение); КонецЦикла; Возврат НовыйМассив; КонецФункции

Оставить комментарий

Пожалуйста, войдите, чтобы комментировать.