fbpx
  • slide 1C cloud 3
  • slide microsft
  • slide aida64
  • Обзор игры EVE Online
  • Переведем ваш 1С на наше облачное хранилище
  • Российская Госдума приняла закон о блокировке сайтов с пиратскими фильмами
  • Warframe. Или как закалялась сталь.
  • Winamp прекращает свое существование
  • У iPhone больше уязвимостей, чем у всех остальных.
  • Microsoft прекращает развитие графического редактора Paint
  • Dj Tro - The new trance [2013]
  • Скрипт установки принтеров Canon LBP на Linux Ubuntu (обновлено)
  • Обход пароля на IPad touch
  • Зачем нужна кнопка
  • Wi-Fi интернет ограниченный доступ. Решение.
  • Pinnacle и телепатический модуль
  • Проблема при обновлении Kubuntu 11.10 desktop x86
  • Почему-то камеры постоянно глючат
  • OneWeb - глобальный проект интернет доступа
  • Как загрузить Windows 8.1/10 в безопасном режиме
  • Грядущий новый формат изображений от Google
  • Прошивка MAC-адресса в интегрированной сетевой карте
  • Тормозит приложение почта (mail) на iMac
  • NVIDIA представила технологию симуляции и рендеринга реалистичной травы - TurfEffects
  • Что нас ждет в грядущих драйверах NVidia 300.**
  • Завершение процессов на удаленном компьютере Windows
  • Оптимизация запуска приложений в Linux
  • Свич или магнитофон ?
  • Assassin's Creed 4: Black Flag. Преимущества игр нового поколения.
  • Microsoft Windows 8.1 Preview доступен для бесплатного скачивания
июнь20

Свернуть массив в 1С

Троцкий Юрий

Свернуть массив в 1С

Один из вариантов решения свертки массива в 1С.

толстый клиент, тонкий клиент

 

   т.к. в 1С еще пока нет встроенной функции или процедуры по сворачиванию массива, предлагаю вам один из вариантов решения этой задачи.

     Из особенностей работы этого кода - он не будет суммировать значения (как работает свертка в таблице значений), в большей степени он больше работает как фильтр от повторяющихся значений. 


Фунцкция СвернутьМассив (МойМассивДляСвертки)

НовыйМассив = Новый Массив; Соответствие = Новый Соответствие; Для каждого ЭлементМассива Из МойМассивДляСвертки Цикл Соответствие.Вставить(ЭлементМассива); КонецЦикла; Для каждого КлючИЗначение Из Соответствие Цикл НовыйМассив.Добавить(КлючИЗначение.Значение); КонецЦикла; Возврат НовыйМассив; КонецФункции

P.S. Так-же мы предоставлям надежное обланое хранилище для ваших баз 1С. Подробнее...

Оставить комментарий

Пожалуйста, войдите, чтобы комментировать.