fbpx
  • slide 1C cloud 3
  • slide microsft
  • slide aida64
  • Доступ к рабочему столу пользователя Windows из 1С
  • Открытие формы в режиме выбора с отбором и возвратом выбора в произвольную процедуру (тонкий клиент)
  • Восстановление БД 1С (SQL) после динамического обновления
  • Установка драйвера ATI Radeon 9000 на Windows 7
  • Ошибка 0x8000000000000002. Решение.
  • С Днем Программиста 2012
  • Скрипт установки принтеров Canon LBP на Linux Ubuntu (обновлено)
  • Dj Tro - The new trance [2013]
  • Свернуть массив в 1С
  • Увеличение размера виртуального и системного диска в Windows Server без остановки VMWare
  • День системного администратора 2019
  • Домашний медиа-сервер своими руками. Часть 1
  • Зачем нужна кнопка
  • Вышло одно из самых ожидаемых дополнений к Mortal Kombat X
  • С Днем системного администратора !!!
  • Sandboxie. Работаем в
  • Семь мифов о сисадминах
  • Вход под Администратором на Windows XP
  • online эмулятор Windows 1.01
  • Winamp прекращает свое существование
  • Тест производительности сервера DELL PowerEdge R210 II
  • Оптимизация запуска приложений в Linux
  • Два диска
  • Анонсирован ОС Android 4.4 KitKat
  • Поднимаем FPS в играх в Windows 10
  • Как качать с торрента
  • Как скрыть файлы в Linux MINT
июнь20

Свернуть массив в 1С

Троцкий Юрий

Свернуть массив в 1С

Один из вариантов решения свертки массива в 1С.

толстый клиент, тонкий клиент

 

   т.к. в 1С еще пока нет встроенной функции или процедуры по сворачиванию массива, предлагаю вам один из вариантов решения этой задачи.

     Из особенностей работы этого кода - он не будет суммировать значения (как работает свертка в таблице значений), в большей степени он больше работает как фильтр от повторяющихся значений. 


Фунцкция СвернутьМассив (МойМассивДляСвертки)

НовыйМассив = Новый Массив; Соответствие = Новый Соответствие; Для каждого ЭлементМассива Из МойМассивДляСвертки Цикл Соответствие.Вставить(ЭлементМассива); КонецЦикла; Для каждого КлючИЗначение Из Соответствие Цикл НовыйМассив.Добавить(КлючИЗначение.Значение); КонецЦикла; Возврат НовыйМассив; КонецФункции

Оставить комментарий

Пожалуйста, войдите, чтобы комментировать.