fbpx
  • slide 1C cloud 3
  • slide microsft
  • slide aida64
  • Полноценная ОС для слабых машин
  • Не запускается Pinnacle Studio 16 на Windows 8.1
  • Wi-Fi интернет ограниченный доступ. Решение.
  • Скрипт для выгрузки базы 1С в DT
  • Dj Tro - TO [2008]
  • Решение ATI Radeon HD3000/4000 Overscan/Underscan
  • Как сделать перчатки сенсорными
  • Динамическая толщина бумаги
  • Чумной барак для сумасшедших фриков
  • Вышел в свет Windows 8.1
  • XCOM Enemy Unknown (2012)
  • Облачное хранилище Hive прекращает деятельность
  • Супер Wi-Fi на iPhone 5 :)
  • Zalman начала процедуру банкротства
  • Неожиданный предмет внутри коробки с монитором AOC F22+
  • Умер Ральф Баер, родитель игровых консолей
  • Как обойти экран блокировки в iOS
  • Новый 3D алгоритм симуляции воды
  • Бездонный телефон
  • Знакомство с Windows 8. Взгляд с близка.
  • Функция хеширования (конвертирования) строки в MD5 для 1С
  • Китайцы назвали WINDOWS 8 угрозой для страны
  • Зачем на самом деле нужны встроенные игры в Windows
  • Что такое интернет
  • Создание загрузочной/установочной USB-Флешки c Linux
  • С днем системного администратора !
  • Sandboxie. Работаем в
июнь20

Свернуть массив в 1С

Троцкий Юрий

Свернуть массив в 1С

Один из вариантов решения свертки массива в 1С.

толстый клиент, тонкий клиент

 

   т.к. в 1С еще пока нет встроенной функции или процедуры по сворачиванию массива, предлагаю вам один из вариантов решения этой задачи.

     Из особенностей работы этого кода - он не будет суммировать значения (как работает свертка в таблице значений), в большей степени он больше работает как фильтр от повторяющихся значений. 


Фунцкция СвернутьМассив (МойМассивДляСвертки)

НовыйМассив = Новый Массив; Соответствие = Новый Соответствие; Для каждого ЭлементМассива Из МойМассивДляСвертки Цикл Соответствие.Вставить(ЭлементМассива); КонецЦикла; Для каждого КлючИЗначение Из Соответствие Цикл НовыйМассив.Добавить(КлючИЗначение.Значение); КонецЦикла; Возврат НовыйМассив; КонецФункции

Оставить комментарий

Пожалуйста, войдите, чтобы комментировать.