fbpx
  • slide 1C cloud 3
  • slide microsft
  • slide aida64
  • Поднимаем FPS в играх в Windows 10
  • Активация Windows 8
  • Разблокировка функции DSR в драйверах Nvidia для старых карт
  • 3DMark 1.0 (2013)
  • Основные команды в Linux
  • Как обойти экран блокировки в iOS
  • Создаем свой караоке-видео
  • Старый новый
  • Серверные процессоры нового поколения Intel Xeon E7 v2
  • Microsoft Windows 8.1 Preview доступен для бесплатного скачивания
  • Бесплатные звонки с VIBER
  • Прошивка MAC-адресса в интегрированной сетевой карте
  • Простая выгрузка/загрузка данных между 1С
  • Новый 3D алгоритм симуляции воды
  • Mortal Kombat Komplete Edition официально анонсирован для PC
  • Названа дата выхода Windows 10
  • Изменения правил для приложений в Google Play
  • Как качать с торрента
  • Печать табличного документа через общую форму печати в УНФ
  • Настройка и подключение Wi-Fi роутера D-Link DIR300
  • GeForce Experience
  • Решение ATI Radeon HD3000/4000 Overscan/Underscan
  • Беспроводная зарядка в телефоне, где ее быть не должно :)
  • Свернуть массив в 1С
  • Неожиданный предмет внутри коробки с монитором AOC F22+
  • Что нас ждет в грядущих драйверах NVidia 300.**
  • Анонсирован Mortal Kombat X
июнь20

Свернуть массив в 1С

Троцкий Юрий

Свернуть массив в 1С

Один из вариантов решения свертки массива в 1С.

толстый клиент, тонкий клиент

 

   т.к. в 1С еще пока нет встроенной функции или процедуры по сворачиванию массива, предлагаю вам один из вариантов решения этой задачи.

     Из особенностей работы этого кода - он не будет суммировать значения (как работает свертка в таблице значений), в большей степени он больше работает как фильтр от повторяющихся значений. 


Фунцкция СвернутьМассив (МойМассивДляСвертки)

НовыйМассив = Новый Массив; Соответствие = Новый Соответствие; Для каждого ЭлементМассива Из МойМассивДляСвертки Цикл Соответствие.Вставить(ЭлементМассива); КонецЦикла; Для каждого КлючИЗначение Из Соответствие Цикл НовыйМассив.Добавить(КлючИЗначение.Значение); КонецЦикла; Возврат НовыйМассив; КонецФункции

Оставить комментарий

Пожалуйста, войдите, чтобы комментировать.