fbpx
  • slide 1C cloud 3
  • slide microsft
  • slide aida64
  • На сайте открыт магазин
  • Создание загрузочной/установочной USB-Флешки c Linux
  • Borderlands 2 заработал на Windows 8
  • Dj Tro - TO [2008]
  • С Днем Программиста 2017
  • Скрипт для выгрузки базы 1С в DT
  • Скрипт установки принтеров Canon LBP на Linux Ubuntu (обновлено)
  • Запуск VMWare ESXi Customizer на несовместимой ОС
  • День системного администратора
  • Как обойти экран блокировки в iOS
  • Полноценная ОС для слабых машин
  • Медленная скорость Интернет/RDP соединения Windows
  • Вывод изображения их Хранилища Значений на форму
  • Иван Царевич,Dj Tro - Твой свет
  • Драйвера Nvidia 296.10
  • Открытие формы в режиме выбора с отбором и возвратом выбора в произвольную процедуру (тонкий клиент)
  • С Днем Программиста 2012
  • Решение ошибки Windows Server 2008 R2
  • Новое на сайте tro.net.ua
  • Первое впечатление о Windows 8 Beta
  • Что означают тесты в AIDA64
  • Китайцы назвали WINDOWS 8 угрозой для страны
  • День системного администратора 2017
  • Сюжетный трейлер Mortal Kombat X
  • AMD представила первые настольные процессоры с частотой до 5,0 ГГц
  • Мой плановый выходной
  • Разблокировка функции DSR в драйверах Nvidia для старых карт
июнь20

Свернуть массив в 1С

Троцкий Юрий

Свернуть массив в 1С

Один из вариантов решения свертки массива в 1С.

толстый клиент, тонкий клиент

 

   т.к. в 1С еще пока нет встроенной функции или процедуры по сворачиванию массива, предлагаю вам один из вариантов решения этой задачи.

     Из особенностей работы этого кода - он не будет суммировать значения (как работает свертка в таблице значений), в большей степени он больше работает как фильтр от повторяющихся значений. 


Фунцкция СвернутьМассив (МойМассивДляСвертки)

НовыйМассив = Новый Массив; Соответствие = Новый Соответствие; Для каждого ЭлементМассива Из МойМассивДляСвертки Цикл Соответствие.Вставить(ЭлементМассива); КонецЦикла; Для каждого КлючИЗначение Из Соответствие Цикл НовыйМассив.Добавить(КлючИЗначение.Значение); КонецЦикла; Возврат НовыйМассив; КонецФункции

P.S. Так-же мы предоставлям надежное обланое хранилище для ваших баз 1С. Подробнее...

Оставить комментарий

Пожалуйста, войдите, чтобы комментировать.