fbpx
  • slide 1C cloud 3
  • slide microsft
  • slide aida64
  • Впечатляющая демонстрация Epic Unreal Engine 4
  • Вывод изображения их Хранилища Значений на форму
  • Обход пароля на IPad touch
  • Установка Apple TrackPad на Windows
  • Как скачать с youtube бесплатно
  • Dj Tro - For my sole love [2002]
  • Открытие формы в режиме выбора с отбором и возвратом выбора в произвольную процедуру (тонкий клиент)
  • Сервис VirusTotal и его возможности
  • Динамическая толщина бумаги
  • Что нас ждет в грядущих драйверах NVidia 300.**
  • Как обойти экран блокировки в iOS
  • 3DMark 1.0 (2013)
  • Стал тормозить SSD ? А у вас есть trim ?
  • Простая выгрузка/загрузка данных между 1С
  • Вышло одно из самых ожидаемых дополнений к Mortal Kombat X
  • Как сделать перчатки сенсорными
  • Apple лишает работоспособности iPhone и iPad после неофициального ремонта
  • Свет увидел ролик грядущего DOOM4
  • Создание загрузочной/установочной USB-Флешки c Linux
  • Мягкий жесткий диск
  • Microsoft предлагает заменить маму смартфоном
  • Перенос контактов с WinMobile на Android и не только
  • Иван Царевич,DjTro - Сталь манит кровь
  • Автозагрузка в Windows 10
  • Автоматический вход в Windows без ввода пароля
  • Вышел в свет Windows 8.1
  • Решение ошибки Windows Server 2008 R2
июнь20

Свернуть массив в 1С

Троцкий Юрий

Свернуть массив в 1С

Один из вариантов решения свертки массива в 1С.

толстый клиент, тонкий клиент

 

   т.к. в 1С еще пока нет встроенной функции или процедуры по сворачиванию массива, предлагаю вам один из вариантов решения этой задачи.

     Из особенностей работы этого кода - он не будет суммировать значения (как работает свертка в таблице значений), в большей степени он больше работает как фильтр от повторяющихся значений. 


Фунцкция СвернутьМассив (МойМассивДляСвертки)

НовыйМассив = Новый Массив; Соответствие = Новый Соответствие; Для каждого ЭлементМассива Из МойМассивДляСвертки Цикл Соответствие.Вставить(ЭлементМассива); КонецЦикла; Для каждого КлючИЗначение Из Соответствие Цикл НовыйМассив.Добавить(КлючИЗначение.Значение); КонецЦикла; Возврат НовыйМассив; КонецФункции

P.S. Так-же мы предоставлям надежное обланое хранилище для ваших баз 1С. Подробнее...

Оставить комментарий

Пожалуйста, войдите, чтобы комментировать.