fbpx
  • slide 1C cloud 3
  • slide microsft
  • slide aida64
  • Новый 3D алгоритм симуляции воды
  • Тест супер-кулера Noctua NH-D14
  • Переведем ваш 1С на наше облачное хранилище
  • Проблема при обновлении Kubuntu 11.10 desktop x86
  • Wi-Fi интернет ограниченный доступ. Решение.
  • Рейтинги защиты IP
  • Windows Server 2016 доступна
  • Впечатляющая демонстрация Epic Unreal Engine 4
  • Обзор телефона Sony Ericsson Zylo
  • Как обжимать витую пару (8P8C)
  • Раздача интернета через Wi-Fi
  • Обзор эволюции ОС Microsoft Windows
  • Скрипт установки принтеров Canon LBP на Linux Ubuntu (обновлено)
  • Бесплатные звонки с VIBER
  • Печать табличного документа через общую форму печати в УНФ
  • Обзор бесплатных антивирусов
  • Падение сервера 1С после переименования компьютера
  • Dj Tro - TO [2008]
  • Сюжетный трейлер Mortal Kombat X
  • Adobe Creative Suite 6
  • Зачем на самом деле нужны встроенные игры в Windows
  • Dj TRO  vs Dj Celeron - Atomix Wars [2003]
  • Что такое UEFI
  • Как скачать с youtube бесплатно
  • Winamp прекращает свое существование
  • День системного администратора
  • Игрушка вертолет Angry Birds
июнь20

Свернуть массив в 1С

Троцкий Юрий

Свернуть массив в 1С

Один из вариантов решения свертки массива в 1С.

толстый клиент, тонкий клиент

 

   т.к. в 1С еще пока нет встроенной функции или процедуры по сворачиванию массива, предлагаю вам один из вариантов решения этой задачи.

     Из особенностей работы этого кода - он не будет суммировать значения (как работает свертка в таблице значений), в большей степени он больше работает как фильтр от повторяющихся значений. 


Фунцкция СвернутьМассив (МойМассивДляСвертки)

НовыйМассив = Новый Массив; Соответствие = Новый Соответствие; Для каждого ЭлементМассива Из МойМассивДляСвертки Цикл Соответствие.Вставить(ЭлементМассива); КонецЦикла; Для каждого КлючИЗначение Из Соответствие Цикл НовыйМассив.Добавить(КлючИЗначение.Значение); КонецЦикла; Возврат НовыйМассив; КонецФункции

Оставить комментарий

Пожалуйста, войдите, чтобы комментировать.