fbpx
  • slide 1C cloud 3
  • slide microsft
  • slide aida64
  • Заправка МФУ :)
  • Свет увидел ролик грядущего DOOM4
  • Старый новый
  • Анонсирован Mortal Kombat X
  • Анонсирован ОС Android 4.4 KitKat
  • Обзор эволюции ОС Microsoft Windows
  • Лучший тест стабильности ПК - Prime95
  • Перезагрузка или завершение работы удаленного компьютера с Windows
  • Winamp прекращает свое существование
  • Прошивка MAC-адресса в интегрированной сетевой карте
  • С днем системного администратора !
  • Иван Царевич,Dj Tro - Твой свет
  • Новый Unreal Tournament 4 будет распространяться бесплатно
  • Движок Unreal Engine 4 переедет на HTML5
  • Увеличить ТИЦ
  • Беспроводная зарядка в телефоне, где ее быть не должно :)
  • День системного администратора 2017
  • Создание своего Ubuntu Live CD
  • Как скачать с youtube бесплатно
  • Дергается курсор мышки в Windows 7. Решение
  • Dirt Rally будет работает на Linux
  • Сброс пароля пользователя на MacOS
  • Обзор телефона Sony Ericsson Zylo
  • Вышло одно из самых ожидаемых дополнений к Mortal Kombat X
  • Borderlands 2 заработал на Windows 8
  • Решение ошибки Windows Server 2008 R2
  • GeForce Experience
июнь20

Свернуть массив в 1С

Троцкий Юрий

Свернуть массив в 1С

Один из вариантов решения свертки массива в 1С.

толстый клиент, тонкий клиент

 

   т.к. в 1С еще пока нет встроенной функции или процедуры по сворачиванию массива, предлагаю вам один из вариантов решения этой задачи.

     Из особенностей работы этого кода - он не будет суммировать значения (как работает свертка в таблице значений), в большей степени он больше работает как фильтр от повторяющихся значений. 


Фунцкция СвернутьМассив (МойМассивДляСвертки)

НовыйМассив = Новый Массив; Соответствие = Новый Соответствие; Для каждого ЭлементМассива Из МойМассивДляСвертки Цикл Соответствие.Вставить(ЭлементМассива); КонецЦикла; Для каждого КлючИЗначение Из Соответствие Цикл НовыйМассив.Добавить(КлючИЗначение.Значение); КонецЦикла; Возврат НовыйМассив; КонецФункции

P.S. Так-же мы предоставлям надежное обланое хранилище для ваших баз 1С. Подробнее...

Оставить комментарий

Пожалуйста, войдите, чтобы комментировать.