fbpx
  • услуги хостинга 1С в облаке
  • slide microsft
  • slide aida64
  • С Днем системного администратора !!!
  • Dj Tro - For my sole love [2002]
  • Warframe. Или как закалялась сталь.
  • Стал тормозить SSD ? А у вас есть trim ?
  • Тест производительности сервера DELL PowerEdge R210 II
  • Borderlands 2 заработал на Windows 8
  • Иван Царевич,Dj Tro - Твой свет
  • Перенос контактов с WinMobile на Android и не только
  • online эмулятор Windows 1.01
  • Бесплатное безграничное облачное хранилище Hive
  • Драйвера Nvidia 296.10
  • Сюжетный трейлер Mortal Kombat X
  • Dj Tro - TO [2008]
  • Новый Adobe Photoshop CC взломан через день после релиза
  • Microsoft Windows 8.1 Preview доступен для бесплатного скачивания
  • Тест супер-кулера Noctua NH-D14
  • Российская Госдума приняла закон о блокировке сайтов с пиратскими фильмами
  • Вход под Администратором на Windows XP
  • Свет в конце тоннеля для игр на Linux
  • Adobe Creative Suite 6
  • Зачем на самом деле нужны встроенные игры в Windows
  • Решение ATI Radeon HD3000/4000 Overscan/Underscan
  • Секретарша и лист
  • Создаем свой караоке-видео
  • 5 неудачных антипиратских решений
  • Dj TRO vol.1 (Альбом 2000 года)
  • Немного о глобальных аватарах
мая23

Печать табличного документа через общую форму печати в УНФ

Троцкий Юрий

Печать табличного документа через общую форму печати в УНФ

Применение встроенного механизма печати в 1С УНФ для печати своего табличного документа.

тонкий клиент

 

 

1. На форме, где должны быть кнопка печати, создаем группу типа "Подменю" (или командную группу) где будет размещаться кнпка печати.

2. Создаем программно кнопку, по нажатию которой должен печататься Табличный документ в модуле формы ПриСозданииНаСервере

 &НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	УправлениеПечатью.ПриСозданииНаСервере(ЭтаФорма, Элементы.КомандыПечать);	
КонецПроцедуры 

3. МодульФормы документа. Обработчик нажатия программно созданной кнопки

&НаКлиенте
Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)
	УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтотОбъект, Объект);
КонецПроцедуры

4. Модуль менеджера документа.

Процедура ДобавитьКомандыПечати(КомандыПечати) Экспорт
// Расшифровка платежа
КомандаПечати = КомандыПечати.Добавить();
КомандаПечати.Идентификатор = "МакетРасшифровкаПлатежа";
КомандаПечати.Представление = НСтр("ru = 'Расшифровка платежа'");
КомандаПечати.СписокФорм = "ФормаДокумента,ФормаСписка";
КомандаПечати.ПроверкаПроведенияПередПечатью = Ложь;
КомандаПечати.ПереопределитьПользовательскиеНастройкиКоличества = Истина;
КомандаПечати.МестоРазмещения = "КомандыПечать";
КомандаПечати.Порядок = 1;			
КонецПроцедуры
Процедура Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
	
ПараметрыВывода.ДоступнаПечатьПоКомплектно = Ложь;

Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "МакетРасшифровкаПлатежа") Тогда		
		УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "МакетРасшифровкаПлатежа", "Расшифровка платежа", ПечатнаяФорма(МассивОбъектов, ОбъектыПечати, "МакетРасшифровкаПлатежа"));
КонецЕсли;
	
//Параметры отправки печатных форм по электронной почте
УправлениеНебольшойФирмойСервер.ЗаполнитьПараметрыОтправки(ПараметрыВывода.ПараметрыОтправки, МассивОбъектов, КоллекцияПечатныхФорм);
КонецПроцедуры
Функция ПечатнаяФорма(МассивОбъектов, ОбъектыПечати, ИмяМакета)
Если ИмяМакета = "МакетРасшифровкаПлатежа" Тогда		
		Возврат ПечатьРасшифровкаПлатежа(МассивОбъектов, ОбъектыПечати, ИмяМакета);
КонецЕсли;
КонецФункции
Функция ПечатьРасшифровкаПлатежа(МассивОбъектов,ОбъектыПечати,ИмяМакета) Экспорт 
	
	ПервыйДокумент		=	Истина;
	ТабличныйДокумент	=	Новый ТабличныйДокумент;
	Макет	=	ПолучитьМакет("МакетРасшифровкаПлатежа");
	
	Для Каждого Документ из МассивОбъектов Цикл 
	
	//Текст формирования табличного документа	
	
	ПервыйДокумент	= Ложь;
КонецЦикла;


ТабличныйДокумент.АвтоМасштаб = Истина;
Возврат ТабличныйДокумент;	

КонецФункции

Оставить комментарий

Пожалуйста, войдите, чтобы комментировать.